Jump to content

SMB connection lost


Recommended Posts

I have been attempting to get a TNI scan completed with no luck. v6.0
SMB makes the connection, installs the agent, scans hardware, starts scanning software, the scan gets to 50% (scanning software) and stops.
This lasts for about an hour before failing stating SMB connection lost.
I have run the program just by double clicking it, runas administrator, as a domain admin, local admin, with debug on, run the tniwinagent /debug.
After running debug, the log only states,
Starting
making local scan
Error loading UninstITL

Link to comment

Hello Paul.

 

We will need some additional info for investigation:

1. Does this problem occur on all Windows nodes, or only on specific ones?
2. Open TNI Options while holding down the Alt key, then go to Logs and change the log level settings to Verbose (all 3 options), and rescan one of those devices. The scanner will display the error and the local path to the .log file. Please send us this log file.
3. After that, you should also do a manual scan of this device, first with the flags:

tniwinagent.exe /debug /verbose /driver:0 ,

and then:

tniwinagent.exe /debug /verbose /driver:3 . After that send us .log and .inv files (if any are generated).

Link to comment

I ran debug, tniwinagent debug -v, in command prompt on Thursday and let it run over the weekend,
Normally a scan would seem to hang at 50% then eventually fail with SMB connection lost.
After running debug, the log shows that that scan finished and the 50% point, took 51670140ms (14 hours) to complete and move on.
I cannot send the logs from the system on which TNI is running.
I am assuming the non-response setting is hitting the max, default is 30 minutes, then killing the scan.

It happens on all windows nodes

 

Edited by Paul
Link to comment

Ran a command prompt debug on a second machine with the same result, hanging for 14 hours on "Computer System" then progresses to finish the scan.
I ran a GUI test scan after changing the timeout parameter to 180 minutes. The scan failed at the expected 3.5 hours.
I am running another GUI test scan after changing the timeout parameter to 900 minutes (15 hours) to see if the scan will finish without running debug from command prompt, as that is the only time it finishes a scan at this point.

Link to comment

Paul, 

We still need you to complete the 2nd and 3rd steps from the previous message and send us the log file for us to investigate the issue.

You can complete step 2 after automatically stopping the scan after 30 minutes.

Step 3 can be done similarly, but you may not wait for the process to stop by itself, but force quit it after 10-15 minutes if it has not ended on its own.
Be sure to run twice with different settings of the /driver flag.

Link to comment
  • 2 weeks later...

Ran both tests with driver flags as requested. Same result with or without flags.
Nothing additional in the log file between any debug test. No .inv file created, the test was stopped after 2 hours.

Again, I cannot supply the log files.

I downgraded to TNI v5 as we run this on several networks, scan finished on one machine or across the entire network in under 2 minutes with full results.

In the TNI v5 log file, Computer Systems scan time was around 700ms as opposed to 51,670,140ms with TNI v6.

 

Link to comment

Unfortunately, we are not able to solve the issue without having any data and logs. There are many reasons that may lead to such behavior. 

We would recommend adding TNI installation folder to the antivirus software whitelist and making exceptions. Additionally, in TNI 6 go to Options -> Scanner and try disabling the "Enable Windows updates scan" option. Try performing scanning again then.

If none of the actions would help, try using the resident agents. Otherwise, send us logs from the above-mentioned actions required to support@softinventive.com

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...