Jump to content

Error: Access Violation

Recommended Posts

I have TNI v1.6.8 installed on my Windows 7 Professional 32-bit workstation that has 4GB of RAM.


Periodcially when I run the 'Refresh audit tool folder', at some point during the refresh as it's reading files, I will get the below error. (I can't say the numbers in the error are the same everytime since I have't previously written them down.)


"Error: Access violation at 0x00432F6A (tried to write to 0x00030FFC), program terminated."


After I click OK on the error, then TNI will terminate and I have to start all over. As I said, it doesn't do it everytime, but enough that it is an annoyance. Other techs have reported this to me also. In some cases, I've just had the techs manually copy the files from the audit tool folder down to their local data folder and then tell them to refresh the data storage folder.


We do have over 6,800 data files stored in our network audit tool folder.


I checked file permissions, and I have "full" control permissions for the folder that TNI is installed in, the local data folder, and also the audit tool folder. I checked the "events.log" file, but it isn't getting updated with any errors or messages and in fact is a few weeks old.


Is this something that other folks have run into? What might be causing this?


Do we perhaps have too many files in our audit folder? Or maybe because of the number of files and the amount of data it has to read/copy over, that may be causing the issue? Which leads me to my next question regarding the next version of TNI. The next version is supposed to have greatly reduced data file sizes. I've had multiple comments about how slow TNI is to do a refresh and also our field sites refuse to do login script scans to a centralized location due to bandwidth concerns, so I'm wondering if the new version of TNI will be arriving soon?

Link to comment

Because of software protection used by TNI, we cannot get any meaningful information from these numbers, so no need to write them down.

I can't rememeber any reports of such kind recently. It's possible that somebody have also ran into this, but solved it in the same manner, by manual copying of files. Perhaps you're right and this is happening because of large amount of data and some memory issues.

Unfortunately the new version is not arriving as soon as we all want it to. However we are working actively on it and most likely it will be availabe in a few months.

Link to comment
  • 4 weeks later...

May be a different issue but I have a brand new installation and it runs fine after install but subsequently will not start giving an error:


Error: access violation at 0x77e634be (tried to read from 0x0017c000), program terminated.


I can reinstall and run the program only once each time.


32bit Server 2003 w/SP2 and 4GB RAM


Please move to new thread if appropriate.




Link to comment

There may be some incompatibility with the particular computer system. Try to install on another computer.

Also, when you reinstall, do you remove the program's installation directory? There are some files that are not removed by the uninstaller, but if they are left, the subsequent install will run as it is not a fresh installation already. These files are "config.ini" and "events.log". Please send them to us at "support@softinventive.com".

Link to comment
  • 4 weeks later...

I know it hasn't been a few months quite yet from when I reported this, but the access violations are becoming quite frustrating. I've had multiple techs and supervisor staff complain about it to me as we continue to encounter them. Unfortunately the events.log file isn't getting updated with any error info, or any other info, for that matter when this happens.


Today, I've encountered the error when refreshing the 'audit tool' folder, which is a storage folder on a local server. I re-ran the audit refresh and then it went through a second time and was able to refresh without problem. However, I then tried to pull up a custom report on our computers as we need to identify what version of antivirus is installed everywhere for an ongoing project we have. The first time, I got the access violation within 10 minutes of starting the report process. I then restarted and after 1 hour and 45 minutes of the report scanning through the data records, it bombed with another access violation and I need to start over again. So after the better part of an entire work day trying to update info and get a report, I haven't completed the task yet.


Sorry, but just had to vent and again pass on the request from all our techs and admin staff for the hope of a timely release of the next version. I don't know that the next version is the magic fix for this, but our folks are pretty frustrated at this point and we're hoping that if nothing else, the significantly smaller data file sizes in the next version will alleviate our field staff concerns about bandwidth and we can do login script scanning state wide for remote sites. (And that the smaller files also help speed up the reporting process too!)

Link to comment

Our apologies for this inconvenience. I understand your concern. Unfortunately, if we start looking into this issue with the current version, this will again delay the development of the next version. On the other hand, not only the data file sizes are smaller in the next version, but also the whole mechanism of their processing. So the next version should solve this problem (and the problems with login script and reporting time). We do the tests with several thousands data files in the data folder and the performance is much higher than in the current version.

Link to comment

Thank you for the follow up reply Zak. We definately would prefer you work on the next version, than look into issues in the current version! I've fielded a lot of complaints and comments on the performance & this error along with questions about when the next version will be available. I'll keep telling them I'm not sure when the next version might be released and to be patient. Thanks.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...