Jump to content

Data file not generated


Recommended Posts

I can ping a machine, yet when I Scan I get the following error "computer-name (10.xxx.xx.xxx):  This computer can be scanned via SMB protocol, but the following error prevents this: SMB: Data file not generated

 

The scan says it finished 100%.  I am scanning with a Domain Admin account, I am able to scan other computers on this same VLAN.   This is happening with about 10% of my clients.  I am not sure how to troubleshoot this. 

Link to post
Share on other sites

Hello,

 

The error "Data file is not generated" is quite rare. We'll need additional information to find out why it occurs.

 

Please open Options while holding down the Alt key, then open Logs and change the log level settings to Verbose (all 3 options). After that, rescan the device and send us the tniwinagent-*.log file that you can find in the following folder:
\AppData\Local\Temp\

Please send the log file for analysis at support@softinventive.com

 

In addition, please check and let us know if TNI successfully scans such devices via RPC. Open Viewer & reports and check if every category contains information.

Link to post
Share on other sites

Hello,

 

The error "Data file is not generated" is quite rare. We'll need additional information to find out why it occurs.

 

Please open Options while holding down the Alt key, then open Logs and change the log level settings to Verbose (all 3 options). After that, rescan the device and send us the tniwinagent-*.log file that you can find in the following folder:

\AppData\Local\Temp\

Please send the log file for analysis at support@softinventive.com

 

In addition, please check and let us know if TNI successfully scans such devices via RPC. Open Viewer & reports and check if every category contains information.

 

 

hi,

 

after restart TNI and start scan network again this error not show any more

Link to post
Share on other sites
  • 1 month later...

I have the same problem randomly. There's not much in the log:

 

NB-HHOSP-9 (172.19.2.9): Dieser Computer kann über das SMB-Protokoll gescannt werden, aber der folgende Fehler verhindert dies: SMB: Datendatei nicht erzeugt

.

.

.

2020.07.31 14:36:51.397 [DEBUG] NB-HHOSP-9 > [85%] AdditionalInfo: 20110 ms
2020.07.31 14:36:51.783 [DEBUG] NB-HHOSP-9 > [85%] MonitorInfo: 328 ms
2020.07.31 14:36:51.952 [DEBUG] NB-HHOSP-9 > [90%] Security: 172 ms
2020.07.31 14:36:51.952 [DEBUG] NB-HHOSP-9 > Databases: not scanned
2020.07.31 14:36:51.952 [DEBUG] NB-HHOSP-9 > USB History: not scanned
2020.07.31 14:36:51.952 [DEBUG] NB-HHOSP-9 > WLAN networks: not scanned
2020.07.31 14:36:51.952 [DEBUG] NB-HHOSP-9 > VMs: not scanned
2020.07.31 14:36:51.952 [DEBUG] NB-HHOSP-9 > [95%] Total scan time: 71437 ms
2020.07.31 14:36:51.952 [DEBUG] NB-HHOSP-9 > Postprocessing...
2020.07.31 14:36:51.960 [DEBUG] zxmlo2 <> nil
2020.07.31 14:36:51.985 [DEBUG] NB-HHOSP-9 > Postprocessing finished
2020.07.31 14:36:51.985 [DEBUG] NB-HHOSP-9 > [95%] Postprocessing: 32 ms
2020.07.31 14:36:52.037 [DEBUG] NB-HHOSP-9 > Scan finished

Link to post
Share on other sites

I have the same problem randomly. There's not much in the log:

 

NB-HHOSP-9 (172.19.2.9): Dieser Computer kann über das SMB-Protokoll gescannt werden, aber der folgende Fehler verhindert dies: SMB: Datendatei nicht erzeugt

.

.

.

2020.07.31 14:36:51.397 [DEBUG] NB-HHOSP-9 > [85%] AdditionalInfo: 20110 ms

2020.07.31 14:36:51.783 [DEBUG] NB-HHOSP-9 > [85%] MonitorInfo: 328 ms

2020.07.31 14:36:51.952 [DEBUG] NB-HHOSP-9 > [90%] Security: 172 ms

2020.07.31 14:36:51.952 [DEBUG] NB-HHOSP-9 > Databases: not scanned

2020.07.31 14:36:51.952 [DEBUG] NB-HHOSP-9 > USB History: not scanned

2020.07.31 14:36:51.952 [DEBUG] NB-HHOSP-9 > WLAN networks: not scanned

2020.07.31 14:36:51.952 [DEBUG] NB-HHOSP-9 > VMs: not scanned

2020.07.31 14:36:51.952 [DEBUG] NB-HHOSP-9 > [95%] Total scan time: 71437 ms

2020.07.31 14:36:51.952 [DEBUG] NB-HHOSP-9 > Postprocessing...

2020.07.31 14:36:51.960 [DEBUG] zxmlo2 nil

2020.07.31 14:36:51.985 [DEBUG] NB-HHOSP-9 > Postprocessing finished

2020.07.31 14:36:51.985 [DEBUG] NB-HHOSP-9 > [95%] Postprocessing: 32 ms

2020.07.31 14:36:52.037 [DEBUG] NB-HHOSP-9 > Scan finished

 

Dear Matthias,

 

Thanks for your message.

 

We need more information to analyze this problem.

 

Please open Options while holding down the Alt key, then open Logs and change the log level settings to Verbose (all 3 options). After that, rescan the device and send us the tniwinagent-*.log file that you can find in the following folder:

\AppData\Local\Temp\

 

Please send the full log at support@softinventive.com

Link to post
Share on other sites

I don't have this kind of option, i can only mark "Debug" in the "Scanner Tab".

And i just have an "tniwinagnt-*.log" file in "C:\ProgramData\Total Network Inventory"

The log above is the only reference to a host with the problem in this file i found.

 

Logfile was send

Link to post
Share on other sites

Dear Matthias,

 

Thank you for sending the logs.

 

We can see that something "correctly" (via the Service Control API) stops the scanning service during the scan. Therefore, the scanning process cannot be finished.

We are not sure what could be stopping the service. Your antivirus could be the culprit. Also please check the system events with the similar timestamp.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...